Currently 100% of consumers in the US cannot pay their Klarna Financing Account statements in the Klarna app
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Aug 26, 2021 - 14:36 CEST
Investigating
We are currently investigating this issue.
Posted Aug 26, 2021 - 12:57 CEST