6.5% of merchants' settlements in NOK currency are experiencing delays
Incident Report for Klarna
Resolved
Incident is resolved and payments have been sent.
Posted Mar 04, 2021 - 11:50 CET
Identified
We have found the issue and will send the NOK payments tomorrow. We apologize for the delay.
Posted Mar 03, 2021 - 17:48 CET
Update
We are continuing to investigate this issue.
Posted Mar 03, 2021 - 15:52 CET
Update
We are continuing to investigate this issue.
Posted Mar 03, 2021 - 14:50 CET
Investigating
6.5% of merchants' settlements in NOK currency might experience a delay in their payouts. This is due to a technical problem that we are currently investigating.
Posted Mar 03, 2021 - 14:24 CET