Customer support system degradation in the US
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 16, 2021 - 15:59 CEST
Investigating
Due to technical issues with internal customer service tools, we might have trouble answering customer queries currently
Posted Sep 16, 2021 - 15:33 CEST