Merchant Operations degradation
Incident Report for Klarna
Update
We are continuing to investigate this issue.
Posted Sep 27, 2024 - 16:12 CEST
Investigating
We are currently experiencing a degradation of Settlements Reports in Settlements App in EU. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Sep 27, 2024 - 16:09 CEST
This incident affects: Merchant Operations (Europe).