Sofort Classic degradation in Austria
Incident Report for Klarna
Resolved
This incident has been resolved. Thank you for your understanding
Posted Apr 13, 2023 - 14:54 CEST
Investigating
We are currently experiencing issues with https://Sofortüberweisung.at. We are investigating the issue and apologize for the inconvenience.
Posted Apr 13, 2023 - 14:42 CEST