UK customers are experiencing disruptions with Slice it service
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 14 days ago. Oct 01, 2019 - 15:46 CEST
Investigating
We have discovered a problem where Slice it rejects customers in the UK. We are currently investigating this and apologise sincerely for the troubles this may cause.
Posted 14 days ago. Oct 01, 2019 - 15:28 CEST
This incident affected: Klarna Payment Methods (KPM).