Payments Degradation in Nordics
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 18:19 CEST
Investigating
We are currently experiencing issues with bank payments going through our payment services provider in the Nordics and SEPA region. This may cause delays to consumer, merchant payouts, and payments made to Klarna.
Our partner is working on restoring this service. Thank you for your patience.
Posted Oct 08, 2024 - 11:17 CEST
This incident affected: Merchant Operations (Europe).