Payments failing from Finland

Incident Report for Klarna

Resolved

This has now been mitigate. Thank you for your patience
Posted Aug 11, 2022 - 11:31 CEST

Investigating

We are currently having issues that may affect card payments from Finland, payments through the App should be unaffected.
We are working to resolve this as soon as possible.
Posted Aug 10, 2022 - 23:01 CEST