Degradation in performance for Klarna Payments through PayBright in Canada
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 16:27 CEST
Update
We are continuing to investigate this issue.
Posted Oct 13, 2021 - 16:00 CEST
Investigating
Our engineering teams have been alerted and are actively investigating. We will update you as soon as we have more information.
Posted Oct 13, 2021 - 14:42 CEST
This incident affected: Klarna Payments (KP).