Integration issues with Klarna payment method for Shopify
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Mar 23, 2023 - 11:35 CET
Update
We are continuing to investigate this issue.
Posted Mar 22, 2023 - 22:45 CET
Investigating
We are currently experiencing issues with the integration for the Klarna payment method (as a direct payment method, not the Klarna payment method within Shopify Payments). If instead of installing the Klarna app in your Shopify store, you get redirect to klarna docs, you can instead:

1. search for the "Klarna" payment method in your Shopify store admin under Settings -> Payments
2. install the "Klarna" app in your store from the "Klarna" payment method
3. click the “Manage” link from the “Klarna” payment method [1], which will redirect you to the Integration Guides app in the Klarna Merchant Portal where you will be able to complete the steps to integrate fully to get Klarna live in your store

We are investigating to find the root cause to get this fixed as soon as possible.

[1] https://docs.klarna.com/platform-solutions/shopify/payments/klarna-payments/#test-mode-custom-app-option-for-testing-in-klarnas-test-environment
Posted Mar 22, 2023 - 22:43 CET