Consumers in Europe are experiencing issues with viewing or paying their orders in the Klarna App
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 08, 2021 - 13:16 CEST
Monitoring
Service has resumed and we are monitoring this actively.
Posted Sep 08, 2021 - 12:39 CEST
Investigating
Consumers in Europe are currently facing delays when viewing or paying their orders in the Klarna App.
Posted Sep 08, 2021 - 11:00 CEST
This incident affected: Klarna App.