Merchants in the EU experience difficulties when searching for orders
Incident Report for Klarna
Resolved
The incident is resolved. We apologize for the inconvenience.
Posted Jan 28, 2021 - 12:12 CET
Investigating
Some merchants in the EU might experience difficulties when searching for orders. We are working to resolve it as soon as possible. We apologize for any inconvenience caused during this time.
Posted Jan 28, 2021 - 09:05 CET
This incident affected: Merchant Portal.