Merchant onboarding system degradation in EU
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 05, 2023 - 02:13 CET
Investigating
We are currently experiencing issues with the merchant onboarding process in EU since 00:44 CEST. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Nov 05, 2023 - 01:48 CET
This incident affected: Merchant Onboarding (Europe).