Merchants based in the EU are currently unable to download their settlement reports since 20th of May.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 20, 2021 - 14:35 CEST
Update
Settlements have been made available to the merchants, we are working on making them available for our partners.
Posted May 20, 2021 - 13:51 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 20, 2021 - 12:41 CEST
Update
We are continuing to investigate this issue.
Posted May 20, 2021 - 11:03 CEST
Investigating
Merchants based in the EU are currently unable to download their settlement reports. We have identified the cause of this problem and we are working to resolve it as soon as possible. We apologize for any inconvenience caused during this time.
Posted May 20, 2021 - 10:45 CEST
This incident affected: Settlements App.