Sofort payment method in the EU has downtime since around 3pm CET
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for the inconvenience.
Posted Mar 09, 2021 - 15:38 CET
Investigating
We are working on fixing the issue with the highest priority. In the meanwhile, we apologize for the inconvenience.
Posted Mar 09, 2021 - 15:15 CET
This incident affected: SOFORT.