US customers unable to make card payments or use Pay In 4 payment method
Incident Report for Klarna
Resolved
The issue has now been resolved. EU was also affected for a shorter period.
Posted Jun 25, 2020 - 16:45 CEST
Investigating
Customers in the US are currently experiencing difficulties making purchases with card payment and Pay In 4 payment method. Our engineers are investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted Jun 25, 2020 - 16:17 CEST
This incident affected: Klarna Card.