Consumers in Europe might not be able to see their disputes in the Klarna App
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 07, 2021 - 12:58 CEST
Investigating
Consumers might not be able to see their disputes in the app.
Posted Oct 07, 2021 - 11:53 CEST
This incident affected: Klarna App.