Issue with order creation with BillPay API
Incident Report for Klarna
Resolved
We experienced issue with the BillPay API, orders could get rejected during 22:06-22:25. The service is back to normal now and we are sorry about the inconvenience.
Posted Oct 24, 2019 - 22:49 CEST
This incident affected: BillPay.