Email PDF Statements Delayed in Great Britain
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Aug 18, 2023 - 18:35 CEST
Update
We are continuing to work on a fix for this issue.
Posted Aug 18, 2023 - 18:19 CEST
Identified
Some Klarna Card customers in Great Britain will see a delay in receiving their monthly PDF Statements,
Customers can log into the APP and see their correct information. Less than 5% of customers are impacted.
We apologize for the delay and are expecting the PDF copies to be emailed on Monday.
Posted Aug 18, 2023 - 17:48 CEST
This incident affected: Klarna Card (Europe).