Login issues with Merchant Portal
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for the disruption.
Posted Mar 18, 2021 - 11:18 CET
Investigating
We are experiencing login issues for Merchant Portal and NKO. Technical teams are investigating the issue. We apologize for the inconvenience this is causing.
Posted Mar 18, 2021 - 11:05 CET
This incident affected: Merchant Portal.