Delay Payment to Canadian Merchants
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Apr 27, 2022 - 07:14 CEST
Monitoring
Payments to Canadian Merchants will have a 1-day delay in receiving their payouts. We apologize for the delay and thank you for your patience.
Posted Apr 26, 2022 - 19:39 CEST