US Merchant portal login unavailable
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 04, 2020 - 23:11 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 04, 2020 - 22:14 CEST
Investigating
Merchants in the US are currently experiencing difficulties logging in to the Merchant Portal. Our engineers are investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted May 04, 2020 - 19:10 CEST
This incident affected: Merchant Portal.