Payments are failing with Rabobank bank in Netherlands through iDEAL
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 11, 2021 - 13:46 CET
Update
This has been confirmed to be an outage on Rabobank's side. They are working on restoring their services.
Posted Nov 11, 2021 - 12:52 CET
Identified
We have noticed an issue with iDeal payments with Rabobank. We are currently monitoring.
Posted Nov 11, 2021 - 12:39 CET