US support numbers are unreachable
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 07, 2021 - 05:51 CEST
Monitoring
The provider has started to see recovery on their service. We will continue to monitor for stability.
Posted Oct 07, 2021 - 05:42 CEST
Identified
Our engineers have found that the issue appears to be upstream of our systems, and we are awaiting updates from our provider.
Posted Oct 07, 2021 - 03:56 CEST
Investigating
Customers in the US are currently experiencing difficulties calling the US customer service line. Chat is unaffected. Our engineers are investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted Oct 07, 2021 - 03:09 CEST
This incident affected: Customer Service.