Purchase visualisation delays in US

Incident Report for Klarna

Resolved

The issue has now been resolved.
Posted Oct 21, 2025 - 03:22 CEST

Monitoring

Services are returning but we are still seeing minor issues with purchase visualisation in the app (some of the newly placed orders are not shown yet). This is due to the extended major outage today at our core infrastructure provider.
Posted Oct 20, 2025 - 23:20 CEST
This incident affected: Klarna App (North America).