Merchant Settlements / Payouts degradation

Incident Report for Klarna

Resolved

All pending merchant payouts have now been successfully triggered. These payouts will be processed according to standard banking timelines.
Posted Apr 10, 2026 - 11:43 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2026 - 13:57 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 09, 2026 - 11:19 CEST

Investigating

We are currently experiencing issues with a subset of our Merchant Settlements / Payouts. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Apr 09, 2026 - 10:37 CEST
This incident affected: Merchant Settlements/Payouts (Europe).