Merchant Stop Request form inaccessible between Oct 15 12:00 - Oct 16 16:00 (CEST)
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 16, 2020 - 16:25 CEST
Identified
Merchants who receive an email from Klarna with instructions to submit a Stop Request are currently unable to open the link provided in the email. We are working to restore access to this form as soon as possible.
Posted Oct 16, 2020 - 16:03 CEST