Customer support service/system degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jan 13, 2023 - 16:51 CET
Investigating
We are currently experiencing a degradation of Klarna Support via chat in the US. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jan 13, 2023 - 16:40 CET
This incident affected: Support (North America).