Services are returning but we are still seeing minor issues with purchase visualisation in the app (some of the newly placed orders are not shown yet)
Posted Oct 20, 2025 - 23:12 CEST
Update
We are continuing to see progress on recovery.
Posted Oct 20, 2025 - 21:21 CEST
Update
We are continuing to see recovery but are not back to normal yet.
Posted Oct 20, 2025 - 19:58 CEST
Update
We are beginning to see recovery in some of our affected systems which is also supported by the core infrastructure provider that is applying mitigation actions.
Posted Oct 20, 2025 - 19:23 CEST
Update
We are still seeing degradation and are closely following the issue on the core infrastructure provider.
Posted Oct 20, 2025 - 17:45 CEST
Update
The core infrastructure provider claims to have found the source of the issue and is continuing to investigate and identify mitigations.
Posted Oct 20, 2025 - 17:10 CEST
Identified
Our core infrastructure provider is experiencing issues again, similar to the outages reported earlier today. We are working with the provider to restore the service as soon as possible. Thank you for your patience.
Posted Oct 20, 2025 - 16:31 CEST
Investigating
We are currently experiencing issues with multiple services in North America (including Klarna purchase API, Klarna App, Merchant Portal, and Customer Service channels) due to a core infrastructure provider. The issue is also impacting orders placed with Shopify. We are working with the provider to restore the service as soon as possible. Thank you for your patience.
Posted Oct 20, 2025 - 16:24 CEST
This incident affected: Purchase API (North America), Merchant Operations (North America), Support (North America), and Klarna App (North America).