Klarna Open Banking degradation for Chase customers in the US
Incident Report for Klarna
Resolved
This incident has been mitigated.
Posted Aug 05, 2022 - 11:15 CEST
Update
We are working on a solution and negotiating with our external provider to continue using Chase's connection.
Posted May 12, 2022 - 14:09 CEST
Identified
The issue is only affecting customers using Chase. We are working to restore the service as soon as possible.
Posted Mar 29, 2022 - 08:54 CEST
Update
We are continuing to investigate this issue.
Posted Mar 25, 2022 - 14:16 CET
Investigating
We are currently experiencing issues with Klarna open banking in the US. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Mar 25, 2022 - 14:06 CET
This incident affected: Klarna Bank Account (Europe) and Open Banking (Europe, North America).