Approval rate drop for ~10% of merchants in Switzerland for the pay later payment method.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Mar 19, 2021 - 00:04 CET
Monitoring
We will continue to monitor the situation.
Posted Mar 18, 2021 - 23:26 CET
This incident affected: Klarna Payments (KP).