Klarna Checkout service issue
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 22, 2017 - 10:22 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jun 22, 2017 - 10:03 CEST
Investigating
We are currently experiencing an issue with the Klarna Checkout service using Internet Explorer 11 in the live environment. We are investigating the issue.
Posted 3 months ago. Jun 22, 2017 - 09:49 CEST
This incident affected: Nordics Klarna Checkout purchases.