Some EU consumers are unable to pay by card with Klarna Checkout and Klarna Payments
Incident Report for Klarna
Resolved
Following a period of monitoring, we have verified that successful card payment rates have returned to expected levels and that the services provided by our payment processing partners have fully recovered. We apologize for any inconvenience caused by this incident.
Posted Aug 30, 2020 - 17:23 CEST
Update
We are continuing to monitor the aforementioned disruption to global Internet connectivity and remain in contact with our upstream payment processing partners.
Posted Aug 30, 2020 - 15:50 CEST
Monitoring
We are aware of a problem with a major international telecommunications provider which is causing widespread disruption to Internet connectivity in Asia, Europe and North America, including our upstream payment processing partners. We will continue to monitor and provide further updates in due course.
Posted Aug 30, 2020 - 14:46 CEST
Investigating
We are currently observing a higher than expected failure rate for card payments in the EU, in particular Visa & American Express card payments which require 3-D Secure authentication. This affects consumers' ability to make card payments through Klarna Checkout and Klarna Payments. We are working with our upstream payment processing partners to resolve this problem as soon as possible.
Posted Aug 30, 2020 - 14:20 CEST
This incident affected: Klarna Checkout (KCO) and Klarna Payments (KP).