Multiple Service degradation in North America

Incident Report for Klarna

Resolved

All affected services have recovered, everything is operational and monitoring is ongoing.
Posted Oct 20, 2025 - 12:18 CEST

Monitoring

Our core infrastructure provider has announced a successful mitigation, and we are now seeing recovery across affected Klarna services. We will continue to closely monitor the situation as system performance stabilises.
Posted Oct 20, 2025 - 11:49 CEST

Update

Our core infrastructure provider has identified a potential root cause and we are continuing to investigate this issue.
Posted Oct 20, 2025 - 11:24 CEST

Identified

Our core infrastructure provider has identified a potential root cause and we are continuing to investigate this issue.
Posted Oct 20, 2025 - 11:22 CEST

Update

Initial investigation points to a broader infrastructure issue. We are collaborating with our provider to narrow down the root cause and implement recovery steps.
Posted Oct 20, 2025 - 10:49 CEST

Update

Our teams are actively investigating service disruptions and collecting logs to better understand the scope and potential source of the issue.
Posted Oct 20, 2025 - 10:38 CEST

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 10:31 CEST

Investigating

We are currently experiencing issues with multiple services in North America (including Klarna purchase API, Klarna App, Merchant Portal, and Customer Service channels) due to a core infrastructure provider. The issue is also impacting orders placed in Shopify globally. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Oct 20, 2025 - 10:16 CEST
This incident affected: Purchase API (North America), Merchant Onboarding (North America), Merchant Operations (North America), Support (North America), Klarna App (North America), Playground - Purchase API (North America), Klarna Card (US), and Settlement API (North America).