Consumers might experience longer response time due to degradation in our chat service
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Aug 20, 2021 - 11:13 CEST
Investigating
We are currently investigating this issue.
Posted Aug 20, 2021 - 10:34 CEST
This incident affected: Customer Service.