Merchants in Europe can't see store names in the Merchant Portal
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 11, 2021 - 11:40 CET
Identified
The technical teams have identified the issue and are working on actions to mitigate it. It impacts less than 1% of the requests.
Posted Nov 11, 2021 - 09:55 CET
Investigating
Technical teams are investigating the issue.
Posted Nov 11, 2021 - 08:52 CET