Payments Degradation in US

Incident Report for Klarna

Resolved

The issue has been fixed.
Posted Jul 03, 2025 - 20:39 CEST

Update

We are continuing to investigate this issue.
Posted Jul 03, 2025 - 20:21 CEST

Investigating

We are experiencing a technical issue with Klarna payments in the US. As a result, shoppers based in the US may not be able to complete their orders. We are investigating this.
Posted Jul 03, 2025 - 20:15 CEST
This incident affected: Purchase API (North America).