Merchants in Denmark and Norway may have delayed payouts
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for any inconvenience this may have caused.
Posted Jan 19, 2021 - 11:01 CET
Investigating
Merchants based in Denmark and Norway may experience a one day delay to their payouts. We are working to resolve it as soon as possible. We apologize for the delay and thank you for your patience.
Posted Jan 18, 2021 - 21:21 CET