Klarna Checkout service issue in Germany, Austria and Nordic countries
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 07, 2018 - 07:17 CET
Investigating
We are currently experiencing an issue with the Klarna Checkout service in the live environment. We are investigating the issue.
Posted about 1 month ago. Nov 07, 2018 - 06:38 CET
This incident affected: Nordics Klarna Checkout purchases.