One Time Card degradation

Incident Report for Klarna

Resolved

We are currently not experiencing anymore issues with One Time Cards.
Posted Mar 28, 2025 - 02:20 CET

Investigating

We are currently experiencing issues with One Time Cards. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Mar 28, 2025 - 01:41 CET