Customer Service Chat & Phone Support is experiencing issues

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 12:56 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2026 - 12:42 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 25, 2026 - 12:41 CET

Investigating

We are currently experiencing issues making it difficult to reach our Customer Service via chat and phone. We are working on solving this issue as soon as possible. Thank you for your patience.
Posted Mar 25, 2026 - 12:10 CET
This incident affected: Customer Service (Europe, North America, Asia Pacific) and Chat and Disputes in the App (Europe, North America, Asia Pacific).