Merchant support hotline in Switzerland unavailable
Incident Report for Klarna
Resolved
The support number is working again.
Posted Feb 25, 2020 - 14:43 CET
Investigating
The merchant support hotline in Switzerland is currently not available. Our engineers are investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted Feb 25, 2020 - 13:01 CET