Payment method Pay Later has degradation for less than 1% of the consumers in Germany and Austria.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 25, 2021 - 12:04 CEST
Investigating
We are currently investigating this issue.
Posted May 25, 2021 - 11:53 CEST
This incident affected: Klarna Payments (KP).