Customers might have been charged multiple times for direct debit
Incident Report for Klarna
Resolved
The issue is resolved. We are back to normal operation.
Posted 3 months ago. May 31, 2019 - 14:21 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. May 29, 2019 - 14:46 CEST
Update
We have identified all the faulty transactions and working on refunding the affected customers. We are sorry for the interruption.
Posted 3 months ago. May 27, 2019 - 15:28 CEST
Identified
We had incident on 22nd May regarding customers being charged multiple times. The error was stopped already. We are working on the refund for affected customers.
Posted 3 months ago. May 27, 2019 - 11:33 CEST