We are currently experiencing issues with payments for Sofort
Incident Report for Klarna
Resolved
The outage has now been resolved, we are sorry for the inconvenience this has caused.
Posted 11 days ago. Sep 06, 2019 - 19:09 CEST
Investigating
We are currently experiencing issues with payments failing for customers and are currently investigating the issue. We are sorry for the disturbance and are working as fast as possible to restore the outage.
Posted 11 days ago. Sep 06, 2019 - 19:04 CEST
This incident affected: SOFORT.