Consumers cannot make Pay Later purchases in NL
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for the disruption.
Posted Mar 19, 2021 - 11:41 CET
Investigating
Technical teams are investigating the issue. We apologize for the inconvenience this is causing.
Posted Mar 19, 2021 - 11:19 CET