Klarna Card signup degradation in the UK
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 25, 2021 - 12:29 CET
Investigating
We are currently experiencing issues with Klarna Card signup in the UK. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Nov 25, 2021 - 10:19 CET
This incident affected: Klarna Card (Europe).