Issue with iDEAL payment method in Netherlands
Incident Report for Klarna
Resolved
Due to an availability issue with payment provider iDEAL some Dutch banks were not available for payments. It was fixed quickly by iDEAL and everything is now working as usual. We apologize for any inconvenience experienced in the meantime.
Posted May 20, 2020 - 12:57 CEST