New customers are unable to create a Klarna account in the US
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 18, 2021 - 05:42 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2021 - 05:36 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 18, 2021 - 05:15 CEST
Update
We are continuing to investigate this issue.
Posted Jul 18, 2021 - 05:00 CEST
Investigating
Customers in the account creation flow are unable to verify their phone numbers. This issue prevents new customers from being able to pay with Klarna. We are currently investigating this issue.
Posted Jul 18, 2021 - 04:43 CEST