Direct bank payment unavailable in Finland
Incident Report for Klarna
Resolved
It is now possible for customers in Finland to make purchases again using direct bank payment. Unsuccessful payment attempts between 09:30 - 11:17 CET will not be automatically processed any further, and customers are therefore advised to re-attempt said payments at their convenience. We thank you for your patience and apologize for the inconvenience.
Posted Mar 06, 2020 - 11:56 CET
Investigating
Customers in Finland are currently unable to make purchases using direct bank payment. Our engineers are investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted Mar 06, 2020 - 10:31 CET
This incident affected: Klarna App and Klarna Checkout (KCO).